Unirse a la Biblioteca de conectores MCP de Harvey
Aprenda cómo su servidor MCP puede conectarse a Harvey para que los clientes gestionen el trabajo jurídico de principio a fin.
Última actualización: 7 oct 2026
Resumen
Harvey es compatible con MCP (Protocolo de Contexto de Modelo), un estándar abierto que permite que herramientas y fuentes de datos externas se conecten directamente a Harvey.
Como socio, puede crear e integrar un servidor MCP que los usuarios puedan utilizar sin salir de Harvey, lo que les ayudará a trabajar de forma más eficiente en diversas tareas jurídicas, tales como:
- Investigar contenido jurídico específico para sintetizarlo en la redacción.
- Buscar y actualizar archivos y contratos.
- Incorporar datos, formatos y visualizaciones preferidos en documentos.
Más de 140, 000 profesionales del derecho en más de 1, 500 firmas de abogados y equipos jurídicos internos en todo el mundo usan Harvey. Al unirse a la Biblioteca de conectores MCP de Harvey, su herramienta se integra directamente en los flujos de trabajo donde los abogados realizan su trabajo principal sin que tengan que salir de Harvey ni cambiar de contexto.
Harvey actúa como cliente para recuperar las credenciales del usuario, hacer solicitudes a su servidor y mostrar la respuesta dentro de la interfaz de Harvey. Un administrador del espacio de trabajo debe habilitar explícitamente su conector antes de que cualquier usuario de su organización pueda conectarse dentro de Harvey.
Habilitar su conector
Para unirse a la Biblioteca de conectores MCP de Harvey, complete este formulario. Le pediremos que envíe información sobre cómo funciona y cómo está diseñada su herramienta, incluidos los protocolos de seguridad, para que podamos revisarla.
Cómo funciona la conexión
Una vez que un administrador del espacio de trabajo habilite su conector dentro de Harvey, los usuarios podrán autenticarse con su servicio para conectar sus cuentas. Harvey se encarga del proceso de autenticación, almacena de forma segura el token del usuario y envía las solicitudes a su servidor en su nombre.
Requisitos de autenticación
Harvey implementa la especificación de autorización MCP (2025-11-25). Asimismo, recomienda que su servidor MCP admita lo siguiente:
Requisito | Detalles |
|---|---|
OAuth 2.1 con PKCE (S256) | Obligatorio. Harvey usa PKCE para todos los flujos de autorización. Su servidor debe admitir el método de intercambio de código S256. |
RFC 8414. Metadatos de AS | Obligatorio. Harvey obtiene los metadatos OAuth de su servidor antes de cualquier inicio de sesión. Publique un documento de metadatos válido en el punto final estándar conocido. |
RFC 9728. Descubrimiento PRM | Obligatorio. Harvey verifica el servidor de autorización que usted haya declarado antes de continuar. |
HTTPS | Obligatorio. Harvey rechaza cualquier URL de conector que no use HTTPS. |
RFC 7591. Registro dinámico de clientes | Opcional. Si es compatible, Harvey se registrará automáticamente como cliente OAuth, lo que simplifica la configuración. |
Gestión de datos
Los controles de Harvey abarcan la autenticación, el almacenamiento de tokens, la limitación del alcance de acceso y el registro de auditoría dentro de Harvey. Una vez que los datos llegan a su servidor MCP, quedan sujetos a su propia política de privacidad, prácticas de manejo de datos y acuerdos con clientes.
Limitaciones actuales de la plataforma
El cliente MCP de Harvey está evolucionando activamente. Las siguientes limitaciones de Harvey son relevantes al diseñar su integración:
Limitación de Harvey | Descripción |
|---|---|
Sin confirmación en tiempo de ejecución para acciones de escritura | Actualmente, Harvey no solicita confirmación a los usuarios antes de que una herramienta conectada ejecute una acción de escritura. Los socios deben definir cuidadosamente el alcance del acceso de escritura y considerar implementar el nivel mínimo de alcance necesario para la funcionalidad prevista del usuario. Harvey evaluará su postura de seguridad integral como parte de la evaluación de los socios de la Biblioteca de Conectores. |
Sin divulgación de capacidades al momento de la conexión | Los usuarios individuales no ven qué operaciones de lectura y escritura puede realizar su conector antes de autenticarse. Los socios deben considerar contar con documentación de administrador clara para que los administradores de los clientes de Harvey puedan evaluar correctamente el conjunto completo de funciones. |
Sin revocación de token automática | Al desconectarse en Harvey, se elimina el token almacenado, pero no se llama al punto final de revocación de su proveedor de identidad. Si necesita una revocación inmediata, implemente también un flujo de revocación por su parte. |
Información adicional
Si desea obtener más información sobre cómo incluir su conector en la lista, puede comunicarse con nuestro equipo de alianzas en partnerships@harvey.ai.
¿Le resultó útil este artículo?