Aderir à Biblioteca de Conectores MCP do Harvey

Saiba como o seu servidor MCP se pode ligar ao Harvey para os clientes realizarem trabalho jurídico de ponta a ponta.

Última atualização: 7/10/2026


Visão geral

O Harvey suporta MCP (Protocolo de Contexto de Modelo), um padrão aberto que permite que ferramentas externas e fontes de dados se liguem diretamente ao Harvey.

Enquanto parceiro, pode criar e integrar um servidor MCP que pode ser usado pelos utilizadores sem saírem do Harvey, ajudando-os a trabalhar mais eficientemente em diversas tarefas jurídicas, nomeadamente:

  • Pesquisar conteúdo jurídico específico para sintetizar na redação
  • Pesquisar e atualizar ficheiros e contratos
  • Incorporar dados, formatos e visualizações preferenciais em documentos

O Harvey é utilizado por mais de 140 mil profissionais do direito em mais de 1500 sociedades de advogados e equipas jurídicas internas em todo o mundo. Aderir à Biblioteca de Conectores MCP do Harvey irá posicionar a sua ferramenta diretamente nos workflows em que os advogados realizam o seu trabalho principal, sem ser necessário sair do Harvey ou mudar de contexto.

O Harvey atua como cliente para obter as credenciais do utilizador, efetuar pedidos ao seu servidor e apresentar a resposta na interface do Harvey. O seu conector tem de ser explicitamente ativado por um administrador do workspace antes que qualquer utilizador da organização dele se possa ligar a ele no Harvey.

Ativar o seu conector

Para aderir à Biblioteca de Conectores MCP do Harvey, preencha este formulário. Iremos pedir-lhe para enviar informações sobre o modo de funcionamento e criação da sua ferramenta, incluindo os protocolos de segurança, a fim de realizarmos a verificação.

Como funciona a ligação

Assim que um administrador do workspace ativar o seu conector no Harvey, os utilizadores podem autenticar-se com o seu serviço para ligar as suas contas. O Harvey gere o handshake de autenticação, armazena em segurança o token do utilizador e encaminha os pedidos para o seu servidor em nome dos utilizadores.

Requisitos de autenticação

O Harvey implementa a Especificação de Autorização MCP (2025-11-25) e recomenda que o seu servidor MCP seja compatível com o seguinte:

Detalhes

de requisitos

OAuth 2.1 com PKCE (S256)

Obrigatório. O Harvey utiliza PKCE para todos os fluxos de autorização. O seu servidor tem de suportar o método de desafio de código S256.

RFC 8414 — Metadados AS

Obrigatório. O Harvey obtém os metadados OAuth do seu servidor antes de iniciar uma sessão. Publique um documento de metadados válido no endpoint conhecido padrão.

RFC 9728 — Descoberta PRM

Obrigatório. O Harvey verifica o servidor de autorização declarado antes de prosseguir.

HTTPS

Obrigatório. O Harvey rejeita qualquer URL de conector que não utilize HTTPS.

RFC 7591 — Registo Dinâmico de Clientes

Opcional. Se suportado, o Harvey irá registar-se automaticamente como cliente OAuth, simplificando a configuração.

Tratamento de dados

Os controlos do Harvey abrangem a autenticação, o armazenamento de tokens, o âmbito de acesso e o registo de auditoria no Harvey. Assim que os dados chegam ao seu servidor MCP, ficam sujeitos à sua própria política de privacidade, práticas de tratamento de dados e acordos com clientes.

Limitações atuais da plataforma

O cliente MCP do Harvey está em constante evolução. As seguintes limitações do Harvey são relevantes no momento de criar a sua integração:

Limitação do Harvey

O que significa

Sem confirmação de ação de escrita em tempo de execução

O Harvey não apresenta atualmente um prompt aos utilizadores antes de uma ferramenta ligada executar uma ação de escrita. Os parceiros devem desenvolver cuidadosamente o âmbito de acesso de escrita e ter em consideração a implementação de nível mínimo de âmbito necessário para a funcionalidade pretendida pelo utilizador. O Harvey irá avaliar a sua postura de segurança global como parte da avaliação dos parceiros da Biblioteca de Conectores.

Sem divulgação de capacidades no momento da ligação

Os utilizadores individuais não visualizam as operações de leitura vs. escrita que o seu conector pode executar antes de se autenticarem. Os parceiros devem considerar a disponibilização de documentação clara aos administradores, de modo que os administradores de clientes Harvey possam avaliar adequadamente o conjunto completo de funcionalidades.

Revogação de token não automática

Desligar-se no Harvey elimina o token armazenado, mas não identifica o endpoint de revogação do seu prestador de identidade. Se necessitar de revogação imediata, disponibilize também um fluxo de revogação do seu lado.

Informações adicionais

Se pretender obter mais informações sobre como listar o seu conector, pode contactar a nossa equipa de parcerias através de partnerships@harvey.ai.

Este artigo foi útil?