Participar da Biblioteca de Conectores MCP da Harvey

Saiba como o seu servidor MCP pode se conectar ao Harvey para permitir que clientes realizem trabalhos jurídicos de ponta a ponta.

Última atualização: 7 de out. de 2026


Visão geral

A Harvey oferece suporte ao MCP (Model Context Protocol), um padrão aberto que permite que ferramentas externas e fontes de dados se conectem diretamente à Harvey.

Como parceiro, você pode criar e integrar um servidor MCP que os usuários podem utilizar sem sair da Harvey, ajudando-os a trabalhar com mais eficiência em diversas tarefas jurídicas, como:

  • Pesquisar conteúdo jurídico específico para sintetizá-lo durante a elaboração de documentos
  • Pesquisar e atualizar arquivos e contratos
  • Inserir em documentos os dados, formatos e visualizações de sua preferência

A Harvey é usada por mais de 140 mil profissionais do direito em mais de 1.500 escritórios de advocacia e equipes jurídicas internas no mundo todo. Participação na Biblioteca de Conectores MCP do Harvey coloca a sua ferramenta diretamente nos workflows em que os advogados realizam suas principais atividades, sem que precisem sair da Harvey ou mudar de contexto.

A Harvey atua como cliente para recuperar as credenciais do usuário, fazer solicitações ao seu servidor e exibir a resposta na interface da Harvey. Um administrador do Workspace deve habilitar explicitamente o seu conector antes que qualquer usuário da organização possa se conectar a ele na Harvey.

Como habilitar seu conector

Para participar da Biblioteca de Conectores MCP do Harvey, preencha este formulário. Vamos pedir que você envie informações sobre como sua ferramenta funciona e foi desenvolvida, incluindo protocolos de segurança, para nossa análise.

Como a conexão funciona

Depois que um administrador do Workspace habilitar o seu conector na Harvey, os usuários poderão se autenticar no seu serviço para conectar suas contas. A Harvey gerencia o handshake de autenticação, armazena o token do usuário com segurança e encaminha solicitações ao seu servidor em nome dele.

Requisitos de autenticação

A Harvey implementa a Especificação de Autorização MCP (2025-11-25). A Harvey recomenda que o seu servidor MCP atenda aos seguintes requisitos:

Requisito

Detalhes

OAuth 2.1 com PKCE (S256)

Obrigatório. A Harvey usa PKCE para todos os fluxos de autorização. Seu servidor deve oferecer suporte ao método de code challenge S256.

RFC 8414 — Metadados do AS

Obrigatório. A Harvey busca os metadados OAuth do seu servidor antes de iniciar qualquer login. Publique um documento de metadados válido no endpoint padrão well-known.

RFC 9728 — Descoberta PRM

Obrigatório. A Harvey verifica seu servidor de autorização declarado antes de prosseguir.

HTTPS

Obrigatório. A Harvey rejeita qualquer URL de conector que não use HTTPS.

RFC 7591 — Registro dinâmico de cliente

Opcional. Se houver suporte, a Harvey se registrará automaticamente como cliente OAuth, simplificando a configuração.

Tratamento de dados

Os controles da Harvey abrangem autenticação, armazenamento de tokens, definição do escopo de acesso e registro de auditoria na Harvey. Depois que os dados chegam ao seu servidor MCP, eles ficam sujeitos à sua própria política de privacidade, às suas práticas de tratamento de dados e aos seus contratos com clientes.

Limitações atuais da plataforma

O cliente MCP da Harvey continua evoluindo. As limitações da Harvey a seguir são relevantes para o projeto da sua integração:

Limitação da Harvey

O que isso significa

Sem confirmação de ação de gravação em tempo de execução

No momento, a Harvey não solicita confirmação aos usuários antes que uma ferramenta conectada execute uma ação de gravação. Os parceiros devem definir cuidadosamente o escopo de acesso para gravação e considerar a implementação do escopo mínimo necessário para a funcionalidade prevista para os usuários. A Harvey avaliará a postura geral de segurança como parte da avaliação de parceiros da Biblioteca de Conectores.

Sem divulgação de recursos no momento da conexão

Antes de se autenticarem, os usuários não veem quais operações de leitura e gravação o conector pode executar. Os parceiros devem considerar disponibilizar documentação clara para administradores, para que os administradores dos clientes da Harvey possam avaliar corretamente o conjunto completo de recursos.

Revogação de token não automática

Ao desconectar o conector na Harvey, o token armazenado é apagado, mas o endpoint de revogação do seu prestador de serviços de identidade não é acionado. Se você precisar de revogação imediata, disponibilize também um fluxo de revogação no seu serviço.

Informações adicionais

Se você quiser mais informações sobre como listar o seu conector, entre em contato com nossa equipe de parcerias pelo e-mail partnerships@harvey.ai.

Este artigo foi útil?