Unirsi alla MCP Connector Library di Harvey

Scopri come il tuo server MCP può connettersi a Harvey per consentire ai clienti di gestire attività legali end-to-end.

Ultimo aggiornamento: 7 ott 2026


Panoramica

Harvey supporta MCP (Model Context Protocol), uno standard aperto che consente a strumenti esterni e fonti di dati di connettersi direttamente a Harvey.

In qualità di partner, puoi creare e integrare un server MCP che gli utenti potranno utilizzare senza uscire da Harvey, aiutandoli a lavorare in modo più efficiente in diverse attività legali come:

  • Ricercare contenuti legali specifici da sintetizzare nella redazione
  • Cercare e aggiornare file e contratti
  • Incorporare nei documenti i dati, le visualizzazioni e i formati preferiti

Harvey è utilizzato da oltre 140.000 professionisti legali in più di 1.500 studi e team legali in tutto il mondo. Entrare a far parte della MCP Connector Library di Harvey inserisce il tuo strumento direttamente nei flussi di lavoro in cui gli avvocati svolgono il loro lavoro principale, senza che debbano lasciare Harvey o cambiare contesto.

Harvey funge da client per recuperare le credenziali degli utenti, inviare richieste al tuo server e visualizzare la risposta all’interno dell’interfaccia di Harvey. Un amministratore dell’area di lavoro deve abilitare esplicitamente il tuo connettore prima che qualsiasi utente della propria organizzazione possa connettersi ad esso all’interno di Harvey.

Attivazione del connettore

Per entrare a far parte della MCP Connector Library di Harvey, compila questo modulo. Ti chiederemo di inviarci informazioni su come è progettato e funziona il tuo strumento, inclusi i protocolli di sicurezza, in modo che possiamo effettuare una revisione.

Come funziona la connessione

Una volta che un amministratore dell’area di lavoro ha abilitato il tuo connettore all’interno di Harvey, gli utenti possono autenticarsi con il tuo servizio per collegare i propri account. Harvey gestisce la procedura di autenticazione, archivia il token dell’utente in modo sicuro e inoltra le richieste al tuo server per loro conto.

Requisiti di autenticazione

Harvey implementa la MCP Authorization Specification (2025-11-25). Harvey consiglia che il tuo server MCP supporti quanto segue:

Requisito

Dettagli

OAuth 2.1 con PKCE (S256)

Obbligatorio. Harvey utilizza PKCE per tutti i flussi di autorizzazione. Il tuo server deve supportare il metodo di code challenge S256.

RFC 8414 — AS Metadata

Obbligatorio. Harvey recupera i metadata OAuth del tuo server prima di avviare qualsiasi accesso. Pubblica un documento di metadati valido sull’endpoint standard noto.

RFC 9728 — PRM Discovery

Obbligatorio. Harvey verifica il server di autorizzazione dichiarato prima di procedere.

HTTPS

Obbligatorio. Harvey rifiuta qualsiasi URL di connettore che non utilizza HTTPS.

RFC 7591 — Dynamic Client Registration

Facoltativo. Se supportata, Harvey si registrerà automaticamente come client OAuth, semplificando la configurazione.

Gestione dei dati

I controlli di Harvey coprono l’autenticazione, l’archiviazione dei token, la definizione dell’accesso tramite scope e il registro di audit all’interno di Harvey. Una volta che i dati raggiungono il tuo server MCP, sono soggetti alla tua informativa sulla privacy, alle tue prassi di gestione dei dati e ai contratti con i clienti.

Limitazioni attuali della piattaforma

Il client MCP di Harvey è in continua evoluzione. Nella progettazione dell’integrazione è necessario tenere conto delle seguenti limitazioni di Harvey:

Limitazione di Harvey

Cosa significa

Nessuna conferma di scrittura in fase di esecuzione

Attualmente Harvey non mostra un prompt agli utenti prima che uno strumento connesso esegua un’azione di scrittura. I partner dovrebbero definire con attenzione lo scope dell’accesso in scrittura e valutare l’implementazione del livello minimo di scope necessario per le funzionalità utente previste. Harvey valuterà il tuo assetto di sicurezza complessivo nell’ambito della valutazione dei partner per la Connector Library.

Nessuna comunicazione delle funzionalità al momento della connessione

Ai singoli utenti non viene mostrato quali operazioni di lettura e di scrittura il tuo connettore può eseguire prima dell’autenticazione. I partner dovrebbero prevedere una documentazione amministrativa chiara, in modo che gli amministratori dei clienti Harvey possano valutare correttamente l’intero set di funzionalità.

Revoca dei token non automatica

La disconnessione in Harvey elimina il token archiviato, ma non richiama l’endpoint di revoca del tuo fornitore di identità. Se hai bisogno di una revoca immediata, prevedi anche dal tuo lato un flusso di revoca.

Informazioni aggiuntive

Se desideri ulteriori informazioni sulla pubblicazione del tuo connettore, puoi contattare il nostro team partnership all’indirizzo partnerships@harvey.ai.

Questo articolo è stato utile?