Rejoindre la bibliothèque de connecteurs MCP de Harvey

Découvrez comment votre serveur MCP peut se connecter à Harvey pour permettre à vos clients de gérer l’ensemble de leurs processus juridiques.

Dernière mise à jour : 7 oct. 2026


Vue d’ensemble

Harvey prend en charge le MCP (Model Context Protocol), une norme ouverte permettant aux outils externes et aux sources de données de se connecter directement à Harvey.

En tant que partenaire, vous pouvez créer et intégrer un serveur MCP que les équipes peuvent utiliser sans quitter Harvey, les aidant ainsi à travailler plus efficacement sur diverses tâches juridiques, telles que :

  • La recherche de contenu juridique spécifique à synthétiser lors de la rédaction
  • La recherche et la mise à jour des fichiers et des contrats
  • L’intégration des données, formats et visualisations privilégiés dans les documents

Harvey est utilisé par plus de 140 000 spécialistes du droit dans plus de 1 500 cabinets d'avocats et équipes juridiques à travers le monde. En rejoignant la bibliothèque de connecteurs MCP de Harvey, votre outil s’intègre directement aux workflows dans lesquels les avocates et les avocats exercent leur activité, sans avoir à quitter Harvey ni à changer de contexte.

Harvey agit en tant que client pour récupérer les identifiants des utilisateurs et des utilisatrices, envoyer des requêtes à votre serveur et afficher la réponse dans l’interface de Harvey. Un administrateur ou une administratrice de l’espace de travail doit explicitement activer votre connecteur avant que toute personne de son organisation puisse s’y connecter dans Harvey.

Activer votre connecteur

Pour rejoindre la bibliothèque de connecteurs MCP de Harvey, remplissez ce formulaire. Nous vous demanderons de soumettre des informations sur le fonctionnement et la conception de votre outil, notamment les protocoles de sécurité, afin que nous puissions les examiner.

Fonctionnement de la connexion

Une fois qu’un administrateur ou une administratrice de l’espace de travail a activé votre connecteur dans Harvey, les équipes peuvent s’authentifier auprès de votre service pour connecter leurs comptes. Harvey gère l’échange d’authentification, stocke le jeton de l’utilisateur ou de l’utilisatrice de manière sécurisée et achemine les requêtes vers votre serveur en leur nom.

Exigences d’authentification

Harvey met en œuvre la spécification d’autorisation MCP (2025-11-25). Nous vous recommandons que votre serveur MCP prenne en charge les éléments suivants :

Exigence

Détails

OAuth 2.1 avec PKCE (S256)

Obligatoire. Harvey utilise PKCE pour tous les flux d’autorisation. Votre serveur doit prendre en charge la méthode de vérification de code S256.

RFC 8414 — Métadonnées AS

Obligatoire. Harvey récupère les métadonnées OAuth de votre serveur avant d’initier toute connexion. Publiez un document de métadonnées valide sur le point d’accès standard.

RFC 9728 — Découverte PRM

Obligatoire. Harvey vérifie votre serveur d’autorisation déclaré avant de poursuivre le processus.

HTTPS

Obligatoire. Harvey rejette toute URL de connecteur n’utilisant pas HTTPS.

RFC 7591 — Enregistrement dynamique de client

Facultatif. Si cette fonctionnalité est prise en charge, Harvey s’enregistrera automatiquement en tant que client OAuth, simplifiant ainsi la configuration.

Traitement des données

Les contrôles de Harvey couvrent l’authentification, le stockage des jetons, la définition de la portée des accès et la journalisation des audits au sein de Harvey. Une fois les données parvenues à votre serveur MCP, elles sont soumises à votre propre politique de confidentialité, à vos pratiques de gestion des données et à vos contrats clients.

Limitations actuelles de la plateforme

Le client MCP de Harvey est en constante évolution. Les limitations suivantes sont à prendre en compte lors de la conception de votre intégration :

Limitation Harvey

Ce que cela signifie

Aucune confirmation avant les actions d’écriture à l’exécution

Harvey ne demande actuellement pas de confirmation aux utilisateurs et utilisatrices avant qu’un outil connecté n’exécute une action d’écriture. Les partenaires doivent donc définir avec soin les autorisations d’écriture et appliquer le principe du moindre privilège en n’accordant que les permissions strictement nécessaires aux fonctionnalités prévues. Harvey évaluera également votre niveau global de sécurité dans le cadre de l’évaluation des partenaires de la bibliothèque de connecteurs.

Les capacités du connecteur ne sont pas affichées au moment de la connexion

Les équipes ne voient pas quelles opérations de lecture ou d’écriture votre connecteur peut effectuer avant de s’authentifier. Les partenaires sont donc encouragés à fournir une documentation claire à destination des administrateurs et administratrices afin que les clients Harvey puissent évaluer précisément les fonctionnalités proposées.

La révocation des jetons n’est pas automatique

Lors de la déconnexion, le jeton stocké est supprimé, mais Harvey n’appelle pas le point de terminaison de révocation de votre fournisseur d’identité. Si une révocation immédiate est nécessaire, vous devez également prévoir un mécanisme de révocation de votre côté.

Informations supplémentaires

Si vous souhaitez obtenir plus d’informations sur le référencement de votre connecteur, vous pouvez contacter notre équipe partenariats à l’adresse partnerships@harvey.ai.

Cet article vous a-t-il été utile ?