Rejoindre la bibliothèque de connecteurs MCP de Harvey

Découvrez comment votre serveur MCP peut se connecter à Harvey pour permettre à vos clients de réaliser des travaux juridiques de bout en bout.

Dernière mise à jour : 7 oct. 2026


Aperçu

Harvey prend en charge MCP (Model Context Protocol), une norme ouverte qui permet à des outils externes et à des sources de données de se connecter directement à Harvey.

En tant que partenaire, vous pouvez créer et intégrer un serveur MCP que les utilisateurs peuvent utiliser sans quitter Harvey, ce qui les aide à travailler plus efficacement sur diverses tâches juridiques, par exemple :

  • Rechercher du contenu juridique précis à synthétiser pour la rédaction
  • Rechercher et mettre à jour des fichiers et des contrats
  • Intégrer des données, des formats et des visualisations préférés dans les documents

Plus de 140 000 professionnel(le)s du droit utilisent Harvey dans plus de 1 500 cabinets et équipes juridiques internes à travers le monde. En rejoignant la bibliothèque de connecteurs MCP de Harvey, vous intégrez votre outil directement dans les flux de travail où les avocat(e)s effectuent leur travail principal, sans qu’il(elle)s aient à quitter Harvey, ni à changer de contexte.

Harvey agit comme client pour récupérer les identifiants des utilisateurs, envoyer des requêtes à votre serveur et afficher la réponse dans l’interface de Harvey. Un administrateur d’espace de travail doit explicitement activer votre connecteur avant que tout utilisateur de son organisation puisse s’y connecter dans Harvey.

Activation de votre connecteur

Pour rejoindre la bibliothèque de connecteurs MCP de Harvey, veuillez remplir ce formulaire. Nous vous demanderons de fournir des renseignements sur le fonctionnement et la conception de votre outil, y compris les protocoles de sécurité, afin que nous puissions les examiner.

Fonctionnement de la connexion

Une fois que l’administrateur de l’espace de travail a activé votre connecteur dans Harvey, les utilisateurs peuvent s’authentifier auprès de votre service pour connecter leurs comptes. Harvey gère l’échange d’authentification, stocke le jeton de l’utilisateur de manière sécurisée et achemine les requêtes vers votre serveur en leur nom.

Exigences d’authentification

Harvey met en œuvre la spécification d’autorisation MCP (2025-11-25). Harvey recommande que votre serveur MCP prenne en charge ce qui suit :

Exigence

Détails

OAuth 2.1 avec PKCE (S256)

Obligatoire. Harvey utilise PKCE pour tous les flux d’autorisation. Votre serveur doit prendre en charge la méthode de défi de code S256.

RFC 8414 — Métadonnées AS

Obligatoire. Harvey récupère les métadonnées OAuth de votre serveur avant de lancer toute connexion. Publiez un document de métadonnées valide au point de terminaison standard « reconnu ».

RFC 9728 — Découverte PRM

Obligatoire. Harvey vérifie le serveur d’autorisation que vous avez déclaré avant de poursuivre.

HTTPS

Obligatoire. Harvey rejette toute URL de connecteur qui n’utilise pas HTTPS.

RFC 7591 — Enregistrement dynamique de client

Facultatif. S’il est pris en charge, Harvey s’enregistrera automatiquement comme client OAuth, ce qui simplifie la configuration.

Gestion des données

Les contrôles de Harvey couvrent l’authentification, le stockage des jetons, la portée des accès et la consignation des journaux d’audit dans Harvey. Une fois que les données atteignent votre serveur MCP, elles sont assujetties à votre propre politique de confidentialité, à vos pratiques de gestion des données et à vos contrats avec les clients.

Limites actuelles de la plateforme

Le client MCP de Harvey évolue activement. Les limitations suivantes de Harvey sont pertinentes lorsque vous concevez votre intégration :

Limitation de Harvey

Ce que cela signifie

Aucune confirmation d’action d’écriture à l’exécution

Harvey ne sollicite actuellement pas les utilisateurs avant qu’un outil connecté n’exécute une action d’écriture. Les partenaires devraient définir soigneusement la portée de l’accès en écriture et envisager de mettre en œuvre le niveau minimal de portée requis pour les fonctionnalités prévues pour les utilisateurs. Harvey évaluera votre niveau de sécurité global dans le cadre de l’évaluation des partenaires de la bibliothèque de connecteurs.

Aucune divulgation des capacités au moment de la connexion

Les utilisateurs individuels ne voient pas les opérations de lecture et d’écriture que votre connecteur peut effectuer avant de s’authentifier. Les partenaires devraient envisager de fournir une documentation d’administration claire, afin que les administrateurs clients de Harvey puissent correctement évaluer l’ensemble des fonctionnalités.

Révocation de jeton non automatique

La déconnexion dans Harvey efface le jeton stocké, mais n’appelle pas le point de terminaison de révocation de votre prestataire d’identité. Si vous exigez une révocation immédiate, mettez également en place un flux de révocation de votre côté.

Informations supplémentaires

Si vous souhaitez obtenir plus de renseignements sur l’inscription de votre connecteur, vous pouvez communiquer avec notre équipe de partenariats à l’adresse partnerships@harvey.ai.

Cet article vous a-t-il été utile?